use strict;
my $str = '\\xn[Lan]Allez, il faut se dépécher, RED !
\\xn[Lan]Allez, il faut se dépécher, RED !
\\bI\'ll stay here, then
\\rFirst, you should restore your Pokémon to full health.
\\rFirst, you should restore your Pokémon to full health.
\\w[signskin]Once you save your game, you can access the Mystery Gift.
\\w[signskin]Once you save your game, you can access the Mystery Gift.
';
my $regex = qr/(?:\\(?:xn|[brw]))*([\s\S]+?)\r?\n/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}