#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^\d\r\n]*\d)\d*\.?\d*(?:\/\d*\.?\d*)?[a-z]*$"
Local $sString = "23.23/100km" & @CRLF & _
"1/3" & @CRLF & _
".23km" & @CRLF & _
"1.mi" & @CRLF & _
"1.2/2.1kg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1a3km" & @CRLF & _
"12.12.12" & @CRLF & _
"1.2.3/12.13km" & @CRLF & _
"12km/12.44km" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")