package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@`)
var str = `@= a b a =@
@= a=@
@=a =@
@= =@
@==@
--- The above should all match, but not the ones below ---
@= a b a @
@= a b a =
= a b a =@
@ a b a =@
@=@
=@@=
=@=
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}