import re
regex = re.compile(r"^(\d)\1{8}$", flags=re.MULTILINE)
test_str = ("888888888\n"
"123456789\n"
"888-88-8888\n"
"123-45-6789\n"
"111-22-3333\n"
"333-33-3333")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")