$re = '/(apples?)/m';
$str = 'I like apples very much. I want an apple.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);