$re = '/{[{:]/';
$str = '{: say|x|Hi{{{x}}}} :}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;