re = /^((\x63\x74\x66)(4)(\x62)(\{B)(\x72)(\x33)\3(\x6b1)(\x6e\x67)(\x5f)\3(\x6c)\11\10(\x54\x68)\7\10(\x480)(\x75)(5)\7\10(\x52)\14\11\7(5)\})$/m
str = 'ctf4b{Br34k1ng_4ll_Th3_H0u53_Rul35}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end