$re = '/http:\/{2}[^\/]+\//';
$str = 'http://shortness.com:101115/localnewsv1/info';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);