const regex = /((\w*)\s*\(((?:(?>[^(){}]+)|(?1))*)\)|\{((?:(?>[^(){}]+)|(?1))*)\})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\w*)\\s*\\(((?:(?>[^(){}]+)|(?1))*)\\)|\\{((?:(?>[^(){}]+)|(?1))*)\\})', 'g')
const str = `function(x){
x_identity=sapply(x, function(i) i*2)
x_squared=sapply(x, function(i){
i^2
}
)
}
x_identity=sapply(x, function(i) i*2)
function(i)
x_squared=sapply(x, function(i){
i^2
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}