re = /((\w*)\s*\(((?:(?>[^(){}]+)|(?1))*)\)|\{((?:(?>[^(){}]+)|(?1))*)\})/
str = 'function(x){
x_identity=sapply(x, function(i) i*2)
x_squared=sapply(x, function(i){
i^2
}
)
}
x_identity=sapply(x, function(i) i*2)
function(i)
x_squared=sapply(x, function(i){
i^2
}
)
function(i){
i^2
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end