$re = '/^"[^:]+:\s*/m';
$str = '"Martin: I\'m hungry."
"Scout Leader: Words and numbers 3"
"Kid #1: more words
';
$subst = "\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;