#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<outcomeDeclaration(.*?)\/>"
Local $sString = "<assessmentItem xmlns="http://www.imsglobal.org/xsd/imsqti_v2p1" xmlns:m="http://www.w3.org/1998/Math/MathML" xmlns:xi="http://www.w3.org/2001/XInclude" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.imsglobal.org/xsd/imsqti_v2p1 http://www.imsglobal.org/xsd/qti/qtiv2p1/imsqti_v2p1.xsd" identifier="IT0000300" title="IT0000300" label="Item Label" adaptive="false" timeDependent="false" toolName="TAO" toolVersion="3.1.0-sprint23">" & @CRLF & _
" <responseDeclaration identifier="_64B7CBD9-8ED4-EC27-D190-BD0751A38A95" cardinality="single" baseType="string"/>" & @CRLF & _
"" & @CRLF & _
" <outcomeDeclaration identifier="SCORE" cardinality="single" baseType="float">" & @CRLF & _
" <defaultValue>" & @CRLF & _
" <value>0</value>" & @CRLF & _
" </defaultValue>" & @CRLF & _
" </outcomeDeclaration>" & @CRLF & _
"" & @CRLF & _
" <outcomeDeclaration identifier="SCORE" cardinality="single" baseType="float"/>" & @CRLF & _
"" & @CRLF & _
" <stylesheet href="style/custom/tao-user-styles.css" type="text/css" media="all" title=""/>" & @CRLF & _
" <itemBody>" & @CRLF & _
" <div class="grid-row">" & @CRLF & _
" <div class="col-12"><prompt>" & @CRLF & _
" <p>300</p>" & @CRLF & _
" </prompt>" & @CRLF & _
" <extendedTextInteraction responseIdentifier="_64B7CBD9-8ED4-EC27-D190-BD0751A38A95" base="10" minStrings="0" format="plain" class="">" & @CRLF & _
" " & @CRLF & _
" </extendedTextInteraction>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </itemBody>"
Local $sSubst = "<outcomeDeclaration$1>\n\t<defaultValue>\n\t\t<value>0</value>\n\t</defaultValue>\n</outcomeDeclaration>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)