re = /\b[A-Za-z]{,7}\d[A-Za-z\d]{7,}\b/m
str = 'https://stackoverflow.com/questions/59800512/ 510557XXXXXX2302 Normal words 1601371803 NhLw6NlR0EksRWkLddEo7NiEvrg https://www.google.com/search?q=some+google+search&oq=some+google+search&aqs=chrome..69i57j0i22i30l8j0i390.4672j0j7&sourceid=chrome&ie=UTF-8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end