re = /(\/\/[^\n]*$|\/(?!\\)\*[\s\S]*?\*(?!\\)\/)/m
str = '/* Test
blabla
*/
// das ist ein
// kommentar test
/** javadoc
* bla blabla
* blablabla
*/
/*
blabla
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end