re = /(?:.*?\/){3}(.[^\/]*)/im
str = 'SN=8029758034.Ref=BFO7Y95B3KN5#resolved/NC339/V928/ClearenceBBF.Brief@{supervisor}/verified
SN=1395939213.#variable/OGT84/PKXC/Undetermined.Thank You@{customer}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end