#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/us[0-9]+\.zopim\.com\/s\/w\/spm\/[0-9a-zA-Z]+\/c\/[0-9]+"
Local $sString = "https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879" & @CRLF & _
"https://us34.zopim.com/s/w/spm/rtyortahxceczngb/c/1507618624653" & @CRLF & _
"https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")