import Foundation
let pattern = #"changed\sfor:\s'+(?<changed_filename>\S+[^'])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Apr 17 08:09:45 clap ossec: Alert Level: 7; Rule: 550 - Integrity checksum changed.; Location: clap->syscheck; classification: ossec,syscheck,; Previous MD5: '0a79ed913a931af0220c0349353ab9ec'; Current MD5: '809a2abe99e979b90e9298d3a052a312'; Previous SHA1: '814125fb17df21b9a91f8b1f839dac91733f0150'; Current SHA1: '3728e27f1f9ab27654ebb72aa6d01219d8624881'; Size changed: from '5780' to '5950'; Integrity checksum changed for: '/home/clapuser/UserDisable/disable.py'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)