re = /([A-Za-z0-9\s\_\(\)]+)\s{2,}--\s{2,}([A-Za-z0-9\s\_\(\)]+)\s{2,}--\s{2,}([A-Za-z0-9\s\_\(\)]+)\s{2,}--\s{2,}([-0-9]+)/m
str = 'VT_Float 32 Bit -- Inductance (Henry) -- read only -- -3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end