re = /^((?<value>\d+)\s?(?<unit>m²|m\^2|cm²|cm\^2|ft|in|m|mm)\s?)+$/
str = '1ft1in'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end