package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\/page(?:\/[\w.-]+)*\/?$`)
var str = `/page
/page/
/page/abc/def/
/pageabcd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}