re = /Py(t|h)/m
str = 'Python language
python algorithm
code Pyhon
Pyon script
more repetitions Pyththththtthon
zero occurrences Py Pyttt-pyPyth'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end