using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Pyt{3}";
string input = @"Python language
python algorithm
code Python
Python script
more repetitions Pyttttthon
zero occurrences Py Py-pyPy ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}