# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[A-Za-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*|\"(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])*\")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])"
test_str = ("David Hills\n"
"Primeresllc@gmail.com\n"
" · Reply · 42w\n"
"Adrian Chu\n"
"badge icon\n"
"adrian@adrianchu.net\n"
" · Reply · 42w\n"
"Nick Bagoshvili\n"
"badge icon\n"
"Nick@ngbroofing.com\n"
" · Reply · 42w\n"
"Grace Wang\n"
"grace@ClarityPropertiesLLC.com\n"
" · Reply · 42w\n"
"Pete Venturo\n"
"That's my neighbor.\n"
" · Reply · 42w\n"
"Hom Teang\n"
"mrteang@gmail.com\n"
" · Reply · 42w\n"
"Derek Stephens\n"
"derek@summitreiholdings.com\n"
" · Reply · 42w\n"
"Julie K Clark\n"
"Julie@seattleinvestorsclub.com\n"
" · Reply · 42w\n"
"Alex Frankov\n"
"alexfrankov@hotmail.com\n"
" · Reply · 42w\n"
"Dawn Armstrong\n"
"Dawnarmstrong&hotmail.com\n"
"Outlook – free personal email and calendar from Microsoft\n"
"OUTLOOK.LIVE.COM\n"
"Outlook – free personal email and calendar from Microsoft\n"
"Outlook – free personal email and calendar from Microsoft\n"
" · Reply · 42w\n"
"Andrey Gulyy\n"
"Andreygulyyre@gmail.com please\n"
" · Reply · 42w\n"
"Viktor Bondarenko\n"
"viktor76@outlook.com\n"
" · Reply · 42w\n"
"Jeremy Macconnell\n"
"Sendmeyourdeals@foursqre.com\n"
" · Reply · 42w\n"
"A Suraphong Liengboonlertchai\n"
"Abuysellproperty@gmail.com. Thx 🙏\n"
" · Reply · 42w\n"
"Kellen Giroux\n"
"info@upraisedproperties.com\n"
" · Reply · 42w\n"
"Anthony Markiie Prado\n"
"Amprado@kw.com\n"
" · Reply · 42w\n"
"Jamil Newman\n"
"Westshoreinvestmentgroup@gmail.com\n"
" · Reply · 42w\n"
"Joe Clark\n"
"Josephclark10@gmail.com\n"
" · Reply · 42w\n"
"Nick Taitano\n"
"It's a great opportunity!\n"
" · Reply · 41w\n"
"Miao Jiang\n"
"mj@everestinvestments.net\n"
" · Reply · 41w\n"
"AJ Sheffield\n"
"aj@theoffmarketdeals.com\n"
" · Reply · 41w\n"
"Cindy Highsmith\n"
"Flyfreelw@gmail.com\n"
" · Reply · 41w\n"
"Steven Wang\n"
"stevenwproperties@gmail.com\n"
" · Reply · 41w\n"
"Miao Jiang\n"
"mj@everestinvestments.net\n"
" · Reply · 40w\n"
"Les Dreeson\n"
"ldreeson@listings.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.