$re = '/([\'\"]?[\[])(.*)([\]][\'\"]?)/';
$str = '["a", "b", "c", "1"]
"["a", "b", "c", "1"]"
\'["a", "b", "c", "1"]\'
[\'a\', \'b\', \'c\', \'1\']
"[\'a\', \'b\', \'c\', \'1\']"
\'[\'a\', \'b\', \'c\', \'1\']\'
[\'a\', \'b\', \'c\', 1]
"[\'a\', \'b\', \'c\', 1]"
\'[\'a\', \'b\', \'c\', 1]\'
[\'a\', \'b\', \'c\', 1]
"[\'a\', \'b\', \'c\', 1]"
\'[\'a\', \'b\', \'c\', 1]\'
[\'a\', \'b\', c, 1]
"[\'a\', \'b\', c, 1]"
\'[\'a\', \'b\', c, 1]\'
[a, b, c, 1]
"[a, b, c, 1]"
\'[a, b, c, 1]\'
[\'a\', \'b\', \'c\', 1]
"[\'a\', \'b\', \'c\', 1]"
\'[\'a\', \'b\', \'c\', 1]\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);