re = /^(1|\d(?=1|9)|[2-79](?=8)|[2-68](?=7)|[2-57](?=6)|[2346](?=5)|[235](?=4)|[24](?=3)|3(?=2))+$/m
str = '12321
12345654321
9
1
2
123421
11231231891323
1234567891111987654321'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end