package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^-\n]+)(?:-([^.\n]+))?\.(.+)`)
var str = `banana-split.taste
banana.taste`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}