re = /U{2,3}D{2,3}(?!D)|D{2,3}U{2,3}(?!U)/m
str = 'Good UUDDDUUU
Bad UDUDUDUU
Bad DUDUDDDU
Bad UDDUDUDU
Bad UDUUUDDD
Bad DDUDDUDD
Good UUDDUUUU
Bad UUUUDUUD
Bad DUUDUDUD
Good UDDUUUDU
Bad DDDDUDDD
Bad DUUUUDDU
Bad UUUUUUUD
Good DUUDDDUD
Bad DDDDUUUU
Good DDDUUDUU
Bad UDUDDUUD
Bad DDDDDDDD
Good DUUUDDDU
Bad DDDDDUUU
Bad DDUUUUUD
Bad UDUUDUDU
Bad DDDUDDUU
Bad UDUDUUUD
Bad DUDUUUDU
Good DDUUDUUD
Bad UDUUUUDU
Bad DDUDUDDD
Bad DUDUDUDU
Bad UDDUDDDU
Bad DDUDDDDD
Bad DUUDUUUD
Good UDDUUDDU
Bad DUUUUUDU
Good DUUDDUUD
Bad DDDDUDUU
Bad UDUDDDUD
Bad DUUUDUDU
Bad DDDDDDUU
Good DDUUUDUD
Bad UDUUDDDU
Bad UDUDUDUD
Good DDUUDDUD
Bad UDUUUDDU
Bad DUDDUDDU
Bad UUDDDDUD
Bad DUDUUDUD
Bad DUDDDDDU
Good UUDDUDUD
Bad UUUUDDUU
Bad UDDDDUDU
Bad DUDUDDUD
Bad UUUUUDUU
Bad UDDUDUUD
Good UDDDUUDU
Bad DUUDUDDU
Bad UDDUUUUD
Bad UUDUDDDD
Bad DUUDDDDU
Bad UDUDDUDU
Bad UUDUUDDD
Bad DUDDUUDU
Good UUDDDUUD
Bad UDUDUUDU
Bad DUDUUUUD
Good UUUDDDUU
Bad DUDDDUDU
Good UUDDUUUD
Bad UUUUDUUU
Bad UDDDDDDU
Bad UUUUDDDD
Bad DUDUDUUD
Bad UUUDUDUU
Bad UUUUUUUU
Bad UDDUDDUD
Bad DDDDUUUD
Bad UDDDUDDU
Bad UUUUUDDD
Bad DUUDUUDU
Good UDDUUDUD
Bad DDDDDUUD
Bad DDUUUUUU
Bad UUDUDUDD
Bad DUDDUDDD
Good DUUDDUDU
Bad UDUDDDDU
Good DDUUDUUU
Bad DUDUUDUU
Bad UUDUUUDD
Bad DUDDDDDD
Bad UDDDDUDD
Bad UDUDUDDU
Bad DUDUDDUU
Good UUUDDUUU
Good DDDUUUDD
Bad UDDUDUUU
Good UDDDUUDD
Bad UUUUDUDD
Bad DUUDUDDD
Bad UUUDUUUU
Bad DDDUDUDD
Bad UDDUUUUU
Bad DDDDUDUD
Bad UUDUDDDU
Bad UUUUUUDD
Bad DUUDDDDD
Bad DDUDUUUU
Bad UDUDDUDD
Bad DDDDDDUD
Bad UUDUUDDU
Good DDUUUDUU
Bad DUDDUUDD
Bad DDUUUUDD
Bad DDUDDUUU
Bad DUDDUDUU
Bad UDUDUUDD
Good DDUUDDUU
Bad DUDUUUUU
Good UUUDDDUD
Bad DUDDDUDD
Good DDUUDUDD
Bad UDDDDDDD
Bad DUDDDDUU
Bad DUUUUDUD
Bad UUUUDDDU
Bad DUDUDUUU
Bad UUUDUDUD
Bad UDDDDUUU
Good DDDUUDDD
Bad UDDUDDUU
Bad UDDDUDDD
Good DUUUDDUD
Bad UUUUUDDU
Bad DUUDUUDD
Bad UDDDUUUU
Bad UDUUDUUD
Bad DDDUDDDD
Good UDDUUDUU
Bad UUDUDUDU
Good DUUDDUDD
Bad UDUUUUUD
Bad DDUDUDUU
Bad UDUDDDDD
Bad UUDUUUDU
Good DDUUUDDD
Bad DDUDDDUU
Bad DUDDUUUU
Bad UDUDUDDD
Good UUUDDUUD
Good DDDUUUDU
Good DDUUDDDD
Bad DUDDDUUU
Bad DUUUUUUD
Bad UUUUDUDU
Bad UUUDUUUD
Bad DDDUDUDU
Bad UDDDDDUU
Bad DUUUDUUD
Bad UUUUUUDU
Bad UDDDUDUU
Bad UDUUDDUD
Bad DDUDUUUD
Bad DDUUUUDU
Bad UDUUUDUD
Bad DDUDDUUD
Good DDUUDUDU
Good DDDUUDDU
Bad DDDUDDDU
Bad DDUDUDUD
Good DDUUUDDU
Bad DDUDDDUD
Good DDUUDDDU
Bad UUDDDDDU
Bad UUDUDDUD
Good UUDDUDDU
Bad UUDUUDUD
Bad UUUDDDDU
Bad UUUDUDDU
Good UUDDDUDU
Bad UUDUDUUD
Bad DUDDUDUD
Good UUDDUUDU
Bad UUDUUUUD
Bad DUDDDDUD
Bad DUUUUDUU
Bad DDDDUUDU
Bad UDDDDUUD
Good UUUDDUDU
Good DUUUDDUU
Bad DDDUUUUD
Bad DDDDDUDU
Good UDDDUUUD
Bad UDUUDUUU
Bad UUDDDDDD
Bad UUUDUUDU
Bad DDDUDUUD
Bad DUDUUDDD
Bad UUDUDDUU
Bad UDUUUUUU
Good UUDDUDDD
Bad DDUDUUDU
Bad DUDUDDDD
Bad UUDUUDUU
Bad DUDDUUUD
Bad UDDUDUDD
Bad DDUDDUDU
Bad DUUDUDUU
Bad UUUDDDDD
Bad DUDDDUUD
Bad DUUUUUUU
Good UDDUUUDD
Bad DDDDUDDU
Bad UDDDDDUD
Bad DUUUUDDD
Good DUUDDDUU
Bad UUUDUDDD
Bad DUUUDUUU
Good DDDUUDUD
Bad UDUDDUUU
Bad DDDDDDDU
Bad UDDDUDUD
Bad UDUUDDUU
Good UUDDDUDD
Bad DUUUDDDD
Bad UDUUDUDD
Bad DDDUDDUD
Bad UUDDDDUU
Bad UDUDUUUU
Bad DUDUUUDD
Bad UUDUDUUU
Bad UDUUUDUU
Good UUDDUUDD
Bad UDUUUUDD
Good UUDDUDUU
Bad DDUDUDDU
Bad UUUUDDUD
Bad DUDUDUDD
Bad UUDUUUUU
Bad DDDDUUDD
Bad UDDUDDDD
Bad DDUDDDDU
Bad UUUUUDUD
Bad DUUDUUUU
Good UUUDDUDD
Bad DDDUUUUU
Bad DDDDDUDD
Good UDDUUDDD
Bad DUUUUUDD
Good DUUDDUUU
Bad UUUDUUDD
Bad DDDUDUUU
Bad UDUDDDUU
Bad DUDUUDDU
Bad DUUUDUDD
Bad UDUUDDDD
Bad DDUDUUDD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end