re = /^(20[1-5]\d)-(0?[1-9]|1[012])-(0?[1-9]|[12]\d|3[01])\s([0-1]\d)|(2[0-3]):([0-5]\d):([0-5]\d)$/m
str = '2022-11-02 00:00:00 bla..
2022-11-02 19:00:00 bla..
..something else 20:00:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end