# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[{2}(?:(?!\]{2}).)+?\|([^\]]+)/[[$1/gx;t' <<< "[[asdfg]] [[abcd|qwerty]]
[[I]] [[be|was]] [[at]] [[the]] [[doctor]]"