using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/content/(?:[^/]*/){3}(?![^/]*/(?:sample1|sample2))[^/]*";
string input = @"/content/atm/en/marketing/royalty/sometext
/content/atm/en/marketing/royalty/sample1
/content/atm/en/marketing/royalty/sometext
/content/atm/en/marketing/royalty/sometext
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}