$re = '/(^|\s+)(\S*)(($|\s+)\2)+/i';
$str = 'She left LEft leFT LEFTnow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);