$re = '/^[A-Za-z0-9 ]+$/m';
$str = 'mayank
Mayank
mayank12
m`ayank
M\'ayank
may-ank
mayank
mayank shankar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);