# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/mypath/check/10\.10/-?123\.11[ ]*=[ ]*/mypath/check/(\d\d)\.\1\d?/"
test_str = ("/mypath/check/10.10/-123.11 = /mypath/check/10.101/-123.112\n"
"/mypath/check/10.10/-123.11 = /mypath/check/10.101/-123.11\n"
"/mypath/check/10.10/-123.11 = /mypath/check/10.10/-123.112\n"
"/mypath/check/10.10/123.11 = /mypath/check/10.101/123.112\n\n"
"/mypath/check/10.10/-123.11 != /mypath/check/10.121/-123.152\n"
"/mypath/check/10.11/-123.11 != /mypath/check/10.12/-123.11")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.