const regex = /^.*?(?=\.)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(?=\\.)', '')
const str = `/path/to/QAQC/Conclusions_Pakistan_2019-09-13_PAK.pdf
/path/to/QAQC/Conclusions_SouthAfrica_2019-09-13_ZAF.pdf
/path/to/QAQC/Conclusions_TheBahamas_2019-09-13_BHS.pdf
/path/to/QAQC/Conclusions_Venezuela_2019-09-13_VEN.pdf
/path/to/QAQC/Conclusions_Pakistan_2019-09-13_YEM.pdf
/path/to/QAQC/Conclusions_Iraq_2019-09-13_IRQ.pdf
/path/to/QAQC/Conclusions_Afghanistan_2019-09-13_AFG.pdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}