# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:https|http){0,1}(?:[:\/]*)(?:[w]{3}\.){0,1}(?:[A-z\.]*)(?:linkedin\.com){0,1}(\/{1}.+\/{1}.+?)(?:\/)*$"
test_str = ("Should match\n"
"https://www.linkedin.com/in/ricardo-alvares\n"
"https://www.linkedincom/in/ricardo-alvares\n"
"www.linkedin.com/in/ricardo-alvares\n"
"linkedin.com/in/ricardo-alvares\n\n"
"Shouldn't match\n"
"https://www.linkedin.com/pub/s/whatever/1230/no/good\n"
"https:/example.com/some/resource/in/should/not/match\n"
"/pub/s/whatever/1230/no/good\n"
"pub/s/whatever/1230/no/good\n"
"/some/resource/in/should/not/match\n"
"some/resource/in/should/not/match\n\n"
"Don't know about these:\n"
"/in/ricardo-alvares\n"
"in/ricardo-alvares\n"
"/doubtfulmatch/in/ricardo-alvares\n"
"doubtfulmatch/in/ricardo-alvares\n"
"https://www.linkedin.com/in/ricardo-alvares/some-action")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.