#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[([^\].]*)\]:\W?(.*)"
Local $sString = "[12:17:05][econ]: cid=0 authed" & @CRLF & _
"[12:17:11][server]: player is ready. ClientID=0 addr=87.100.133.110:64762" & @CRLF & _
"[12:17:11][game]: Teams are balanced (red=1 blue=0)" & @CRLF & _
"[12:17:11][server]: player has entered the game. ClientID=0 addr=87.100.133.110:64762" & @CRLF & _
"[12:17:11][game]: team_join player='0:wavi' team=0" & @CRLF & _
"[12:17:13][game]: pickup player='0:wavi' item=3" & @CRLF & _
"[12:17:25][game]: pickup player='0:wavi' item=2" & @CRLF & _
"[12:17:33][game]: flag_grab player='0:wavi' team=0" & @CRLF & _
"[12:17:34][game]: pickup player='0:wavi' item=1" & @CRLF & _
"[12:17:34][game]: pickup player='0:wavi' item=1" & @CRLF & _
"[12:17:43][game]: pickup player='0:wavi' item=0" & @CRLF & _
"[12:17:44][game]: flag_capture player='0:wavi' team=0 time=11.38" & @CRLF & _
"[12:17:48][game]: kill killer='0:0:wavi' victim='0:0:wavi' weapon=-1 special=0" & @CRLF & _
"[12:17:52][server]: client dropped. cid=0 addr=87.100.133.110:64762 reason=''" & @CRLF & _
"[12:17:52][game]: kill killer='0:0:wavi' victim='0:0:wavi' weapon=-3 special=0" & @CRLF & _
"[12:17:52][game]: leave player='0:wavi'" & @CRLF & _
"[12:17:52][game]: Teams are balanced (red=0 blue=0)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[econ]: cid=0 authed" & @CRLF & _
"[server]: player is ready. ClientID=0 addr=87.100.133.110:64762" & @CRLF & _
"[game]: Teams are balanced (red=1 blue=0)" & @CRLF & _
"[server]: player has entered the game. ClientID=0 addr=87.100.133.110:64762" & @CRLF & _
"[game]: team_join player='0:wavi' team=0" & @CRLF & _
"[game]: pickup player='0:wavi' item=1" & @CRLF & _
"[game]: pickup player='0:wavi' item=1" & @CRLF & _
"[game]: pickup player='0:wavi' item=1" & @CRLF & _
"[game]: pickup player='0:wavi' item=2" & @CRLF & _
"[game]: pickup player='0:wavi' item=4" & @CRLF & _
"[game]: flag_grab player='0:wavi'" & @CRLF & _
"[game]: pickup player='0:wavi' item=2" & @CRLF & _
"[game]: pickup player='0:wavi' item=0" & @CRLF & _
"[game]: pickup player='0:wavi' item=3" & @CRLF & _
"[game]: flag_capture player='0:wavi'" & @CRLF & _
"[game]: pickup player='0:wavi' item=2" & @CRLF & _
"[game]: kill killer='0:wavi' victim='0:wavi' weapon=-1 special=0" & @CRLF & _
"[server]: client dropped. cid=0 addr=87.100.133.110:64762 reason=''" & @CRLF & _
"[game]: leave player='0:wavi'" & @CRLF & _
"[game]: Teams are balanced (red=0 blue=0)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")