import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "[-−]? #dash or minus\n"
+ "(?: [1-9]\\d{0,2}\n"
+ " (?:,\\d{3})*\n"
+ " | 0\n"
+ ")\n"
+ "(?:\\.\\d+)?\n"
+ "$";
final String string = "Valid\n"
+ "0\n"
+ "0.00\n"
+ "0.1\n"
+ "0.01\n"
+ "0.001\n"
+ "0.0001\n"
+ "0.00001\n"
+ "1.0\n"
+ "1\n"
+ "8\n"
+ "9\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "20\n"
+ "21\n"
+ "99\n"
+ "100\n"
+ "101\n"
+ "111\n"
+ "999\n"
+ "1,000\n"
+ "1,001\n"
+ "2,100\n"
+ "9,999\n"
+ "10,000\n"
+ "999,999\n"
+ "1,000,000\n"
+ "1,000,001\n\n"
+ "Invalid\n"
+ "00\n"
+ "0,1\n"
+ "0,001\n"
+ "0.0000 1\n"
+ "0,100\n"
+ "9999\n"
+ ",111\n"
+ "999,9999,999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}