import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\d+\\ turns\\)";
final String string = "padding: 0;\n"
+ "font-size: 16pt;\n"
+ "width: 50%;\n"
+ "height: 20vh;\n"
+ "margin-right: 12px;\n"
+ "padding-right: -12.5px;\n"
+ "(7 turns)\n"
+ "Uncroaked Piker (10 turns) asd\n"
+ " asd Uncroaked Woof (6 turns)";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}