use strict;
my $str = 'http://raw.githubusercontent.com:3/FlagB&rew/Sharkive/master/3ds/000400ddddddddddddddddddddddddddd.dddddd
git@github.com:yorha93/shell-scripts.git';
my $regex = qr/(?(DEFINE)(?'cont'(htt(ps|p)|(sft |ft)(ps|p)|ss(l|h)|smb|git|network|file|smtp|vnc))(?'pg'(?<port>\:[0-3][0-5][0-5][0-6][0-5])|(?<gitusr>\:[a-zA-Z0-9\-]{3,39}))) (?<pro>(?P>cont)\:\/\/)(?<dom>[[:alnum:]]+\.[[:alnum:]]+\.[[:alnum:]]{2,6})(?P>pg){0,1}(?<fp>\/[[:print:]]+\/){0,}(?<file>[[:graph:]]+\.[[:alnum:]]{1,6}){0,1}/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}