#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msu)s"
Local $sString = "" & @CRLF & _
"AGUAS DE JAHU S/A" & @CRLF & _
"AV CDOR ITALO MAZZEI 1250 " & @CRLF & _
"JD PLANALTO" & @CRLF & _
"17208-550 JAHU SP" & @CRLF & _
"" & @CRLF & _
"Roteiro de leitura Lote Cliente" & @CRLF & _
"" & @CRLF & _
"JAUAE014-0000000000 16 712125422" & @CRLF & _
"" & @CRLF & _
"ATENDIMENTO PN SEU CÓDIGO CONTA/MÊS VENCIMENTO TOTAL A PAGAR (R$)" & @CRLF & _
"" & @CRLF & _
"0800 770 4140 712125422 4002597682 MAR/2020 20/04/2020 1.707,52" & @CRLF & _
"www.cpflempresas.com.br Segunda Via" & @CRLF & _
"" & @CRLF & _
"Nota Fiscal " & @CRLF & _
"" & @CRLF & _
"Conta de Energia Elétrica" & @CRLF & _
"" & @CRLF & _
"Nº. 122708149 série C" & @CRLF & _
"" & @CRLF & _
"Data de Emissão 31/03/2020" & @CRLF & _
"" & @CRLF & _
"Data de Apresentação 03/04/2020" & @CRLF & _
"" & @CRLF & _
"Pág. 1 de 2" & @CRLF & _
"" & @CRLF & _
"Reservado ao fisco" & @CRLF & _
"" & @CRLF & _
"4D7D.B1F7.29EC.6D42.4E26.6E48.1E0A.CA68" & @CRLF & _
"" & @CRLF & _
" DADOS DO SEU CÓDIGO" & @CRLF & _
"" & @CRLF & _
"AGUAS DE JAHU S/A" & @CRLF & _
"� � � � � � � � � � � � " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Tarifa Verde-A4 Serviço Público Ag/Esg/San Emp Econ Mista M" & @CRLF & _
"" & @CRLF & _
"R JADIR DA COSTA JUNIOR S/N1 AR 1 CNPJ 20.918.034/0001-77" & @CRLF & _
"" & @CRLF & _
"17200-000JAHU - SP Inscrição Estadual: 401144028116" & @CRLF & _
"" & @CRLF & _
"Conta Contrato Nº.330001669282" & @CRLF & _
"" & @CRLF & _
" DISCRIMINAÇÃO DA OPERAÇÃO - RESERVADO AO FISCO" & @CRLF & _
"" & @CRLF & _
"Cod." & @CRLF & _
"" & @CRLF & _
"115" & @CRLF & _
"" & @CRLF & _
"Descrição da Operação" & @CRLF & _
"" & @CRLF & _
"Nº. 327907025127" & @CRLF & _
"Mês" & @CRLF & _
"" & @CRLF & _
"Ref." & @CRLF & _
"" & @CRLF & _
"Quant." & @CRLF & _
"" & @CRLF & _
"Registrada" & @CRLF & _
"" & @CRLF & _
"Quant. " & @CRLF & _
"" & @CRLF & _
"Faturada" & @CRLF & _
"" & @CRLF & _
"Unid." & @CRLF & _
"" & @CRLF & _
"Med." & @CRLF & _
"" & @CRLF & _
"Tarifa com" & @CRLF & _
"" & @CRLF & _
"Tributos" & @CRLF & _
"" & @CRLF & _
"Valor Total " & @CRLF & _
"" & @CRLF & _
"Operação " & @CRLF & _
"" & @CRLF & _
"Base Cálculo" & @CRLF & _
"" & @CRLF & _
"ICMS" & @CRLF & _
"" & @CRLF & _
"Aliq." & @CRLF & _
"" & @CRLF & _
"ICMS" & @CRLF & _
"" & @CRLF & _
"ICMS Base Cálculo" & @CRLF & _
"" & @CRLF & _
"PIS/COFINS" & @CRLF & _
"" & @CRLF & _
"PIS" & @CRLF & _
"" & @CRLF & _
"0,59%" & @CRLF & _
"" & @CRLF & _
"COFINS" & @CRLF & _
"" & @CRLF & _
"2,78%" & @CRLF & _
"" & @CRLF & _
"0605 Consumo Ponta - TUSD-12.00% MAR/20 38,540 38,540 kWh 0,81240270 31,31 31,31 18,00 5,64 31,31 0,18 0,87 " & @CRLF & _
"" & @CRLF & _
"0605 Consumo Fora Ponta -TUSD-12.00% MAR/20 687,160 687,160 kWh 0,08466733 58,18 58,18 18,00 10,47 58,18 0,34 1,62 " & @CRLF & _
"" & @CRLF & _
"0601 Cons Ponta - TE-12.00% MAR/20 38,540 38,540 kWh 0,48858330 18,83 18,83 18,00 3,39 18,83 0,11 0,52 " & @CRLF & _
"" & @CRLF & _
"0601 Cons FPonta TE-12.00% MAR/20 687,160 687,160 kWh 0,29466209 202,48 202,48 18,00 36,45 202,48 1,19 5,63 " & @CRLF & _
"" & @CRLF & _
"0602 Demanda - TUSD-12.00% MAR/20 106,272 106,272 KW 11,58329570 1.230,98 1.230,98 18,00 221,58 1.230,98 7,26 34,22 " & @CRLF & _
"" & @CRLF & _
"0699 Subvenção Tarifária MAR/20 210,26 210,26 18,00 37,84 210,26 1,25 5,85 " & @CRLF & _
"" & @CRLF & _
"Fator Potencia Ponta 0,59190" & @CRLF & _
"" & @CRLF & _
"Fator Potencia F Ponta 0,69539" & @CRLF & _
"" & @CRLF & _
"Subtotal 1.752,04 " & @CRLF & _
"" & @CRLF & _
"0805 Multa por Atraso Pgto 6,72 " & @CRLF & _
"" & @CRLF & _
"0804 Juros de Mora JAN/20 3,10 " & @CRLF & _
"" & @CRLF & _
"0603 Religação Normal 99,79 " & @CRLF & _
"" & @CRLF & _
"Total Distribuidora 1.861,65 " & @CRLF & _
"" & @CRLF & _
"0807 Contrib. Custeio IP-CIP Municipal MAR/20 10,63 " & @CRLF & _
"" & @CRLF & _
"0899 Custo Adicional de Entrega 0,56 " & @CRLF & _
"" & @CRLF & _
"Total Devoluções/Ajustes 11,19 " & @CRLF & _
"" & @CRLF & _
"0999 Credito de Subvenção Tarifária 165,32-" & @CRLF & _
"" & @CRLF & _
"Total a Pagar 1.707,52 " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" TOTAL CONSOLIDADO 1.707,52 1.752,04 315,37 1.752,04 10,33 48,71 � � " & @CRLF & _
" � � " & @CRLF & _
" � � � � � � � � � � � � � � � � � � � � �� � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � � �� � � � ! " # � $% � & � � ' ( ) & ( * + ! � ) $ , � * ! # �� - . / / 0 1 2 . 3 4 5 , * ! ( % 6 7 8 9 : ; 7 8 < => ? @ ? A @ > ? > ?B C D E F G H E I J K L M N K O P L Q R S T P LU U ? ? ? V W W X > Y > Z L K S [ S \ S ] S ^ _ ` V a b ? b c d >e f g e h i j i k e l e m n j f i h n g o p i q g e r i n m p i j f e s t f t g e u m t v f e w x y z t g i hm i g e { y { | | x e i r } e n p i g g n ~ i m i j n f o g } e y p i j s v n l } h v e ~ i } l n j f n" & @CRLF & _
"Autenticação Mecânica | { { { { {
{
w { { { | { w w w w
w
{ { | | { { { w w " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" 8 < = A ? ? > d X b W Y >" & @CRLF & _
"AGUAS DE JAHU S/A" & @CRLF & _
"AV CDOR ITALO MAZZEI 1250 " & @CRLF & _
"" & @CRLF & _
"Nota Fiscal " & @CRLF & _
"" & @CRLF & _
"Conta de Energia Elétrica" & @CRLF & _
"" & @CRLF & _
"Nº. 122708149 série C" & @CRLF & _
"" & @CRLF & _
"Data de Emissão 31/03/2020" & @CRLF & _
"" & @CRLF & _
"Data de Apresentação 03/04/2020" & @CRLF & _
"" & @CRLF & _
"Pág. 2 de 2" & @CRLF & _
"" & @CRLF & _
"Demanda Contratada" & @CRLF & _
"Única 140" & @CRLF & _
"Ponta" & @CRLF & _
"Fora Ponta" & @CRLF & _
"Geração" & @CRLF & _
"" & @CRLF & _
"Energia Contratada" & @CRLF & _
"Único" & @CRLF & _
"Ponta" & @CRLF & _
"Fora Ponta" & @CRLF & _
"Reservado" & @CRLF & _
"" & @CRLF & _
"Bandeira Tarifárias" & @CRLF & _
"Verde : De 22 a 29/02 - 08 Dias" & @CRLF & _
"Verde : De 01 a 25/03 - 25 Dias" & @CRLF & _
"Total : 33 Dias" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Micro/Minigeração" & @CRLF & _
"" & @CRLF & _
" DATAS DA LEITURA" & @CRLF & _
"" & @CRLF & _
"Leitura Anterior 22/02/2020" & @CRLF & _
"" & @CRLF & _
"Leitura Atual 25/03/2020" & @CRLF & _
"" & @CRLF & _
"Qtd de dias 33" & @CRLF & _
"" & @CRLF & _
"Próxima Leitura Prevista 25/04/2020" & @CRLF & _
"" & @CRLF & _
" EQUIPAMENTOS DE MEDIÇÃO" & @CRLF & _
"" & @CRLF & _
"Energia Ativa 40124871" & @CRLF & _
"" & @CRLF & _
"Energia Reativa 40124871" & @CRLF & _
"" & @CRLF & _
"Taxa de perda 2,5" & @CRLF & _
"" & @CRLF & _
" DADOS DE LEITURA" & @CRLF & _
"" & @CRLF & _
"U.M. Atual Anter Ft.Multip" & @CRLF & _
"" & @CRLF & _
"kWh Ponta 000062 000015 0,80000" & @CRLF & _
"" & @CRLF & _
"kWh F.Ponta 001281 000443 0,80000" & @CRLF & _
"" & @CRLF & _
"kWh Reserv." & @CRLF & _
"" & @CRLF & _
"kW Ponta 001024 000000 0,08000" & @CRLF & _
"" & @CRLF & _
"kW F.Ponta 001296 000000 0,08000" & @CRLF & _
"" & @CRLF & _
"kW Reserv." & @CRLF & _
"" & @CRLF & _
"Ufer Ponta 000047 000020 0,80000" & @CRLF & _
"" & @CRLF & _
"Ufer F.Ponta 000388 000156 0,80000" & @CRLF & _
"" & @CRLF & _
"Ufer Reserv." & @CRLF & _
"" & @CRLF & _
"kWh Inj. Ponta" & @CRLF & _
"" & @CRLF & _
"kWh Inj. FPonta" & @CRLF & _
"" & @CRLF & _
"kWh Inj. Reserv" & @CRLF & _
"" & @CRLF & _
" NÍVEL DE TENSÃO" & @CRLF & _
"" & @CRLF & _
"Contratado 13.200" & @CRLF & _
"" & @CRLF & _
"Mínimo 12.276" & @CRLF & _
"" & @CRLF & _
"Máximo 13.860" & @CRLF & _
"" & @CRLF & _
" INDICADORES DE CONTINUIDADE" & @CRLF & _
" DO FORNECIMENTO DE ENERGIA" & @CRLF & _
"" & @CRLF & _
"Jaú 3-Antonina" & @CRLF & _
"" & @CRLF & _
"DIC FIC DMIC DICRI" & @CRLF & _
"" & @CRLF & _
"Padrão mensal 4,59 3,11 2,52 12,22" & @CRLF & _
"" & @CRLF & _
"Padrão Trimestral 6,71 4,35" & @CRLF & _
"" & @CRLF & _
"Padrão Anual 13,43 8,71" & @CRLF & _
"" & @CRLF & _
"Apurado mensal 0,00 0,00 0,00 0,00" & @CRLF & _
"" & @CRLF & _
"Período de apuração mês: 01/2020" & @CRLF & _
"" & @CRLF & _
"Valor mensal do EUSD: R$ 310,50" & @CRLF & _
"" & @CRLF & _
"TARIFA ANEEL" & @CRLF & _
"" & @CRLF & _
"kWh Ponta TE R$ 0,38443680 kW Único R$ 9,10800000 " & @CRLF & _
"" & @CRLF & _
"kWh Fponta TE R$ 0,23170400 " & @CRLF & _
"" & @CRLF & _
"kWh Ponta TUSD R$ 0,63902080 " & @CRLF & _
"" & @CRLF & _
"kWh FPonta TUSD R$ 0,06658960 7 7 7 8 9 : ? U @ > ? > ? ¡ ¢ £" & @CRLF & _
"kWh Dias" & @CRLF & _
"" & @CRLF & _
"2020 MAR" & @CRLF & _
"lllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll 38,00 33" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" ¤ ¥ ¦ § ¡ ¢ £" & @CRLF & _
"kWh Dias" & @CRLF & _
"" & @CRLF & _
"2020 MAR" & @CRLF & _
"lllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll 687,00 33" & @CRLF & _
"" & @CRLF & _
"¨ § ¦ ¡ £" & @CRLF & _
"kW Dias" & @CRLF & _
"" & @CRLF & _
"2020 MAR" & @CRLF & _
"lllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll 106,00 33" & @CRLF & _
"" & @CRLF & _
"k g n © e r i p v } n j f nª « ¬ ® ¬ ¯ « ° ® ± ° ² « ² ³ ° ° ® ´ µ ¶ ® « ± « · ¸ ¹ « ² ³ ° º « · » ± ¬ ° ¸ ® ¬ ° ² ® ® ¶ ´ ¸ ¬ « ´ « « ¶ ¸ ¼ « ® ¶ ¸ ½ ± « ¾ ¿ ³ ² ® ° ± « ¼ « ± ¶ « ² ® ® ¬ ® ¶ » ¸ « ® · À ¶ ¸ Á « Âà ³ · ¸ Á ¸ ® ³ ° ° ® ¶ Ä ¸ ¾ ³ ° ² ¸ ° µ ³ ¬ Å Ä ® ¸ ° ® ´ ¬ ³ ° ° ³ ° ¸ ® Á ³ ´ ¶ « µ ¸ ² ® ¹ ® ° ® » ± ¶ « ¬ ¾ « ® ¶ ® ° ® ¶ Ä ® ´ « ¸ ° ® ´ µ ³ µ « ¶ « Ä ³ Á Æ ® ´ ° ® ± ² ¸ « Ç « Ç ² ¸ « ª « ¸ ° ¸ ¬ ¼ ³ ¶ ´ « ¾ È ® ° « Á ® ° ° ® ³ ® ¬ ² ® ¶ ® ¾ ³ É ± ® Á ³ ¬ ° « ¬ ³ Ä ® ¶ ° ³ ² ® ° ± « Á ³ ¬ « Â} j s i g m e ~ Ê n h h i q g n e s e f t g e" & @CRLF & _
"Excepcionalmente este mês estamos postergando sua data de vcto.," & @CRLF & _
"" & @CRLF & _
"de modo a atender os prazos da Resolução 414/ANEEL/2010." & @CRLF & _
"" & @CRLF & _
"Período teste de 12/19 até 03/20 para ajuste do fator de potência" & @CRLF & _
"" & @CRLF & _
"conforme Res. 414/ANEEL/2010. Os valores corretos seriam:" & @CRLF & _
"" & @CRLF & _
"Reativo Excedente Ponta: 22 kWh - R$ 6,14" & @CRLF & _
"" & @CRLF & _
"Reativo Excedente Fora Ponta: 190 kWh - R$ 52,84" & @CRLF & _
"" & @CRLF & _
"Dem Reativo Excedente: 36 kWh - R$ 367,99" & @CRLF & _
"" & @CRLF & _
"Período de teste de 12/2019 até 03/2020, para ajuste da" & @CRLF & _
"" & @CRLF & _
"Demanda de Potência, conforme Res. 414/ANEEL/2010. e } h i } m k i g f e j f n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")