$re = '/\d{17}/m';
$str = 'РАСЧЕТНЫЙ СЧЕТ ИНДИВИДУАЛЬНЫЙ ПРЕДПРИНИМАТЕЛЬ ВАСИЛИЙ Р/С 12342123122222212 В ФИЛИАЛ № 1234 БАНКА ВТБ (ПАО)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);