$re = '/\.((?:19[2-9]|20[0-2])\d.*)?/m';
$str = 'This.Is.The.Movie.Title.2012.details.of.the.resolution.and.audio.format.mkv
Blade.Runner.2049.2017.details.of.the.resolution.and.audio.format.mkv
Broadway.Melody.of.1940.1940.details.of.the.resolution.and.audio.format.mkv';
$subst = " (?1- $1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;