import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*?_.*?)(?!(?:[\\d\\w]+?\\.)?\\-[\\w\\d\\.\\-]*?)(?![\\w\\d]+?\\-\\.(?:[\\d\\w\\.\\-]+?))(?=[\\w\\d])(?=[\\w\\d\\.\\-]*?\\.+[\\w\\d\\.\\-]*?)(?![\\w\\d\\.\\-]{254})(?!(?:\\.?[\\w\\d\\-\\.]*?[\\w\\d\\-]{64,}\\.)+?)[\\w\\d\\.\\-]+?(?<![\\w\\d\\-\\.]*?\\.[\\d]+?)(?<=[\\w\\d\\-]{2,})(?<![\\w\\d\\-]{25})$";
final String string = "# TEST\n\n"
+ "## List of valid domains:\n"
+ "www.google.com\n"
+ "google.com\n"
+ "mkyong123.com\n"
+ "mkyong-info.com\n"
+ "sub.mkyong.com\n"
+ "sub.mkyong-info.com\n"
+ "mkyong.com.au\n"
+ "g.co\n"
+ "a.12E\n"
+ "mkyong.t.t.co\n"
+ "xn--stackoverflow.com\n"
+ "stackoverflow.xn--com\n"
+ "xn--d1ai6ai.xn--p1ai\n"
+ "stackoverflow.co.uk\n"
+ "a.xn--wgbh1c\n"
+ "1.2.3.4.com\n"
+ "x.XN--VERMGENSBERATUNG-PWB\n"
+ "abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.com\n"
+ "www.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.com\n"
+ "abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.com\n\n"
+ "## List of invalid domains:\n"
+ "http://google.com\n"
+ "http://www.google.com\n"
+ "dot.\n"
+ "space com\n"
+ "under_score.com\n"
+ "underscore.c_om\n"
+ "-dash.com\n"
+ "dash-.com\n"
+ "sub.-dash.com\n"
+ "sub-.dash.com\n"
+ "-.com\n"
+ "-com\n"
+ ".com\n"
+ "com\n"
+ "mx.gmail.com.\n"
+ "mkyong.t.t.c\n"
+ "mkyong,com\n"
+ "mkyong.com/users\n"
+ "a.123\n"
+ "x.XN--VERMGENSBERATUNG-PWBB\n"
+ "abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijkk.com\n"
+ "www.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijkk.co.uk\n"
+ "abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcde.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcdefghijk.comm\n"
+ "0123456789 +-.,!@#$%^&*();\\\\/|<>\\\"\\'\n"
+ "12345 -98.7 3.141 .6180 9,000 +42\n\n\n"
+ "HELP\n\n"
+ "https://github.com/c-hive/guides/blob/57cbbf72f1152214a160f9be8a57e2c4dc868cfd/etc/regex.md#domains\n"
+ "# allowed chars\n"
+ "[\\w\\d\\.\\-]\n\n\n"
+ "EXPLAIN\n\n"
+ "# once upon a time...\n"
+ "^\n"
+ "# doesn't contain underscore (this is so that we can use \\w alter on)\n"
+ "(?![\\w\\d\\.\\-]*?_[\\w\\d\\.\\-]*?)\n"
+ "# doesn't contain dash at the beginning of a label\n"
+ "(?!(?:[\\d\\w]+?\\.)?\\-[\\w\\d\\.\\-]*?)\n"
+ "# doesn't contain dash at the end of a label\n"
+ "(?![\\w\\d]+?\\-\\.(?:[\\d\\w\\.\\-]+?))\n"
+ "# starts with a non-limit char\n"
+ "(?=[\\w\\d\\])\n"
+ "# contains at least 1 dot\n"
+ "(?=[\\w\\d\\.\\-]*?\\.+[\\w\\d\\.\\-]*?)\n"
+ "# not longer than 253 chars\n"
+ "(?![\\w\\d\\.\\-]{253})\n"
+ "# doesn't contain a label longer than 63 char\n"
+ "(?!(?:\\.?[\\w\\d\\-\\.]*?[\\w\\d\\-]{64,}\\.)+?)\n"
+ "# allowed chars\n"
+ "[\\w\\d\\.\\-]+?\n"
+ "# TLD is not digit-only\n"
+ "(?<![\\w\\d\\-\\.]*?\\.[\\d]+?)\n"
+ "# TLD is at least 2 characters\n"
+ "(?<=[\\w\\d\\-]{2,})\n"
+ "# TLD is at most 24 characters\n"
+ "(?<![\\w\\d\\-]{25})\n"
+ "# the end\n"
+ "&";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}