re = /^(?:[^_]*_){3}([^_]*_[^_]*)/m
str = 'Images/LINE 58/AGSD/LUC/L58_AFND_K3_2022-10-12_23-53-18_Color_ID_511.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end