import re
regex = re.compile(r"^(\d+)-(0[1-9]|1[012])-(0[1-9]|[12]\d|3[01])_([01]\d|2[0-3]):([0-5]\d):([0-5]\d|60)(\.\d+)?(([Zz])|([\+|\-]([01]\d+|2[0-3])))", flags=re.MULTILINE)
test_str = ("2018-05-12_04:26:57.525+0000: [I] Accepted and connected to 9.4.127.199 ng.zc2.zurich <c0n9>\n"
"2018-05-28_09:01:01.825813-04:00 elastic-nfs-test systemd: Created slice User Slice of root.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")