use strict;
my $str = 'http://foo.com/blah_blah
http://foo.com/blah_blah/
http://foo.com/blah_blah_(wikipedia)
http://foo.com/blah_blah_(wikipedia)_(again)
http://www.example.com/wpstyle/?p=364
https://www.example.com/foo/?bar=baz&inga=42&quux
http://✪df.ws/123
www.https//:fgdv.com
test.https://www.xflowpay.com
http://fr.wikipedia.org/wiki/%C3%89l%C3%A9phant
www.exldfcsdf/dcsdfv
http://userid:password@example.com:8080
http://userid:password@example.com:8080/
http://userid@example.com
http://userid@example.com/
http://userid@example.com:8080
http://userid@example.com:8080/
http://userid:password@example.com
http://userid:password@example.com/
http://142.42.1.1/
http://142.42.1.1:8080/
http://➡.ws/䨹
http://www.mysite.com/myresumé.html
http://foo.com/blah_(wikipedia)#cite-1
http://foo.com/blah_(wikipedia)_blah#cite-1
http://code.google.com/events/#&product=browser
http://foo.com/unicode_(✪)_in_parens
http://foo.com/(something)?after=parens
http://code.google.com/events/#&product=browser
ftp://foo.bar/baz
http://j.mp
http://foo.bar/?q=Test%20URL-encoded%20stuff
http://-.~_!$&\'()*+,;=:%40:80%2f::::::@example.com
http://1337.net
http://a.b-c.de
http://223.255.255.254
https://foo_bar.example.com/
https://regex101.com/
http://
http://.
http://../
http://##
///a
http:///a
foo.com
rdar://1234
http:// shouldfail.com
h://test
http://foo.bar/foo(bar)baz quux
http://10.1.1.255
http://-a.b.co
http://a.b--c.de/
ftps://foo.bar/
http://3628126748
http://.www.foo.bar./
http://www.foo.bar./
http://.www.foo.bar/
http://10.1.1.254
dc';
my $regex = qr/^(((https|http):\/\/)?([a-z0-9@:%._\+~#=]{1,256}\.)+[a-z0-9:()]{1,20}+(\/[a-z0-9_():@.]+)*(\/)?((\?|#).*)?|(website_not_available))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}