import re
regex = re.compile(r"^(((https|http):\/\/)?([a-z0-9@:%._\+~#=]{1,256}\.)+[a-z0-9:()]{1,20}+(\/[a-z0-9_():@.]+)*(\/)?((\?|#).*)?|(website_not_available))", flags=re.MULTILINE)
test_str = ("http://foo.com/blah_blah\n"
"http://foo.com/blah_blah/\n"
"http://foo.com/blah_blah_(wikipedia)\n"
"http://foo.com/blah_blah_(wikipedia)_(again)\n"
"http://www.example.com/wpstyle/?p=364\n"
"https://www.example.com/foo/?bar=baz&inga=42&quux\n"
"http://✪df.ws/123\n"
"www.https//:fgdv.com\n"
"test.https://www.xflowpay.com\n"
"http://fr.wikipedia.org/wiki/%C3%89l%C3%A9phant\n"
"www.exldfcsdf/dcsdfv\n"
"http://userid:password@example.com:8080\n"
"http://userid:password@example.com:8080/\n"
"http://userid@example.com\n"
"http://userid@example.com/\n"
"http://userid@example.com:8080\n"
"http://userid@example.com:8080/\n"
"http://userid:password@example.com\n"
"http://userid:password@example.com/\n"
"http://142.42.1.1/\n"
"http://142.42.1.1:8080/\n"
"http://➡.ws/䨹\n"
"http://www.mysite.com/myresumé.html\n"
"http://foo.com/blah_(wikipedia)#cite-1\n"
"http://foo.com/blah_(wikipedia)_blah#cite-1 \n"
"http://code.google.com/events/#&product=browser\n"
"http://foo.com/unicode_(✪)_in_parens\n"
"http://foo.com/(something)?after=parens\n"
"http://code.google.com/events/#&product=browser\n"
"ftp://foo.bar/baz\n"
"http://j.mp\n"
"http://foo.bar/?q=Test%20URL-encoded%20stuff\n"
"http://-.~_!$&'()*+,;=:%40:80%2f::::::@example.com \n"
"http://1337.net\n"
"http://a.b-c.de\n"
"http://223.255.255.254\n"
"https://foo_bar.example.com/\n\n"
"https://regex101.com/\n\n\n"
"http://\n"
"http://.\n"
"http://../\n"
"http://##\n"
"///a\n"
"http:///a\n"
"foo.com\n"
"rdar://1234\n"
"http:// shouldfail.com\n"
"h://test\n"
"http://foo.bar/foo(bar)baz quux\n"
"http://10.1.1.255\n"
"http://-a.b.co\n"
"http://a.b--c.de/\n"
"ftps://foo.bar/\n"
"http://3628126748\n"
"http://.www.foo.bar./\n"
"http://www.foo.bar./\n"
"http://.www.foo.bar/\n"
"http://10.1.1.254\n"
"dc\n"
"dvxdc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")