package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)\h+(.*?)(\.[^.\n]*)?$`)
var str = `000035 ZSMS_1.mp3
000035 1OMNA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}