$re = '/\bdata-plugin="([a-zA-Z0-9\(\),\']*)/';
$str = '<div class="plugin" data-plugin="function(1,2,\'func\')"></div>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);