# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(MacBook[1-7],\d|MacBookAir[1-4],\d|MacBookPro[1-8],\d|Macmini[1-5],\d|iMac(1[0-2]|[4-9]|),\d|^MacPro[1-5],\d$)"
test_str = ("Model information: https://support.apple.com/en-us/HT210222\n"
"Published Date: February 01, 2021\n\n"
"Validation: https://regex101.com/r/p5r9WT/3/\n\n"
"This regex is exact. No new models are supported.\n\n"
"(MacBookAir[5-9]|MacBookPro(9|1[0-6])|MacPro[6-7]|iMac(Pro1|1[3-9]|20)|MacBook(10|9|8)|Macmini[6-8]),\\d\n\n"
"pattern matches:\n\n"
"https://support.apple.com/en-us/HT201608\n\n"
"Supported:\n"
"MacBook10,1\n"
"MacBook9,1\n"
"MacBook8,1\n\n"
"Unsupported:\n"
"MacBook7,1\n"
"MacBook6,1\n"
"MacBook5,2\n"
"MacBook5,1\n"
"MacBook4,1\n"
"MacBook3,1\n"
"MacBook2,1\n"
"MacBook1,1\n\n"
"https://support.apple.com/en-us/HT201862\n\n"
"Supported:\n"
"MacBookAir9,1\n"
"MacBookAir8,2\n"
"MacBookAir8,1\n"
"MacBookAir7,2\n"
"MacBookAir7,2\n"
"MacBookAir7,1\n"
"MacBookAir6,2\n"
"MacBookAir6,1\n"
"MacBookAir6,2\n"
"MacBookAir6,1\n"
"MacBookAir5,2\n"
"MacBookAir5,1\n\n"
"Unsupported:\n"
"MacBookAir4,2\n"
"MacBookAir4,1\n"
"MacBookAir3,2\n"
"MacBookAir3,1\n"
"MacBookAir2,1\n"
"MacBookAir1,1\n\n"
"https://support.apple.com/en-us/HT201300\n\n"
"Supported:\n"
"MacBookPro16,3\n"
"MacBookPro16,2\n"
"MacBookPro16,1\n"
"MacBookPro15,4\n"
"MacBookPro15,3\n"
"MacBookPro15,2\n"
"MacBookPro15,1\n"
"MacBookPro14,3\n"
"MacBookPro14,2\n"
"MacBookPro14,1\n"
"MacBookPro13,3\n"
"MacBookPro13,2\n"
"MacBookPro13,1\n"
"MacBookPro11,5\n"
"MacBookPro11,4\n"
"MacBookPro12,1\n"
"MacBookPro11,3\n"
"MacBookPro11,2\n"
"MacBookPro11,1\n"
"MacBookPro10,1\n"
"MacBookPro11,1\n"
"MacBookPro10,2\n"
"MacBookPro10,1\n"
"MacBookPro9,2\n"
"MacBookPro9,1\n\n"
"Unsupported:\n"
"MacBookPro8,3\n"
"MacBookPro8,2\n"
"MacBookPro8,1\n"
"MacBookPro7,1\n"
"MacBookPro6,2\n"
"MacBookPro6,1\n"
"MacBookPro5,5\n"
"MacBookPro5,4\n"
"MacBookPro5,3\n"
"MacBookPro5,2\n"
"MacBookPro5,1\n"
"MacBookPro4,1\n"
"MacBookPro3,1\n"
"MacBookPro2,2\n"
"MacBookPro2,1\n"
"MacBookPro1,2\n"
"MacBookPro1,1\n\n"
"https://support.apple.com/en-us/HT201894\n\n"
"Supported:\n"
"Macmini8,1\n"
"Macmini7,1\n"
"Macmini6,2\n"
"Macmini6,1\n\n"
"Unsupported:\n"
"Macmini5,3\n"
"Macmini5,2\n"
"Macmini5,1\n"
"Macmini4,1\n"
"Macmini3,1\n"
"Macmini2,1\n"
"Macmini1,1\n\n"
"https://support.apple.com/en-us/HT201634\n\n"
"Supported:\n"
"iMac20,2\n"
"iMac20,1\n"
"iMac19,2\n"
"iMac19,1\n"
"iMac18,3\n"
"iMac18,2\n"
"iMac18,1\n"
"iMac17,1\n"
"iMac16,2\n"
"iMac16,1\n"
"iMac15,1\n"
"iMac14,4\n"
"iMac14,3\n"
"iMac14,2\n"
"iMac14,1\n"
"iMac13,2\n"
"iMac13,1\n\n"
"Unsupported:\n"
"iMac12,2\n"
"iMac12,1\n"
"iMac11,3\n"
"iMac11,2\n"
"iMac11,1\n"
"iMac10,1\n"
"iMac9,1\n"
"iMac8,1\n"
"iMac7,1\n"
"iMac6,1\n"
"iMac5,2\n"
"iMac5,1\n"
"iMac4,2\n"
"iMac4,1\n"
"iMac,1\n\n"
"https://support.apple.com/en-us/HT210222\n\n"
"Supported:\n"
"iMacPro1,1\n\n"
"https://support.apple.com/en-us/HT202888\n\n"
"Supported:\n"
"MacPro7,1\n"
"MacPro6,1\n\n"
"Unsupported:\n"
"MacPro5,1\n"
"MacPro4,1\n"
"MacPro3,1\n"
"MacPro2,1\n"
"MacPro1,1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.